GLSA-201812-05 : EDE: Privilege escalation

High Nessus Plugin ID 119483

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201812-05 (EDE: Privilege escalation)

An untrusted search path vulnerability was discovered in EDE.
Impact :

A local attacker could escalate his privileges via a specially crafted Lisp expression in a Project.ede file in the directory or a parent directory of an opened file.
Workaround :

There is no known workaround at this time.

Solution

All EDE users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=app-xemacs/ede-1.07'

See Also

https://security.gentoo.org/glsa/201812-05

Plugin Details

Severity: High

ID: 119483

File Name: gentoo_GLSA-201812-05.nasl

Version: 1.1

Type: local

Published: 2018/12/07

Modified: 2018/12/07

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:ede, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/12/06

Reference Information

CVE: CVE-2012-0035

GLSA: 201812-05