RHEL 6 : rubygem packages (RHSA-2013:0728)

Medium Nessus Plugin ID 119438

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

This update fixes one security issue in multiple rubygem packages for
Red Hat OpenShift Enterprise 1.1.3.

The Red Hat Security Response Team has rated this update as having
moderate security impact. A Common Vulnerability Scoring System (CVSS)
base score, which gives a detailed severity rating, is available from
the CVE link in the References section.

Ruby is an extensible, interpreted, object-oriented, scripting
language. It has features to process text files and to do system
management tasks.

It was found that documentation created by RDoc was vulnerable to a
cross-site scripting (XSS) attack. If such documentation was
accessible over a network, and a remote attacker could trick a user
into visiting a specially crafted URL, it would lead to arbitrary web
script execution in the context of the user's session. As RDoc is used
for creating documentation for Ruby source files (such as classes,
modules, and so on), it is not a common scenario to make such
documentation accessible over the network. (CVE-2013-0256)

This update provides a number of updated rubygem packages that have
had their documentation regenerated with a corrected version of RDoc.

Red Hat would like to thank Eric Hodel of RDoc upstream for reporting
this issue. Upstream acknowledges Evgeny Ermakov as the original
reporter.

Users of Red Hat OpenShift Enterprise 1.1.3 are advised to upgrade to
these updated packages, which correct this issue.

Solution

Update the affected packages.

See Also

https://access.redhat.com/errata/RHSA-2013:0728

https://access.redhat.com/security/cve/cve-2013-0256

Plugin Details

Severity: Medium

ID: 119438

File Name: redhat-RHSA-2013-0728.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/12/06

Modified: 2018/12/06

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-activesupport, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-bcrypt-ruby, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-bcrypt-ruby-debuginfo, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-bson, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-chunky_png, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-ci_reporter, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-compass, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-fastthread, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-fastthread-debuginfo, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-haml, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-http_connection, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-rack, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-rack-test, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-rspec, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-treetop, p-cpe:/a:redhat:enterprise_linux:ruby193-rubygem-xml-simple, cpe:/o:redhat:enterprise_linux:6

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/04/09

Reference Information

CVE: CVE-2013-0256

BID: 57785

RHSA: 2013:0728