Adobe Flash Player for Mac <= 31.0.0.153 (APSB18-42)

High Nessus Plugin ID 119424

Synopsis

The remote macOS or Mac OSX host has a browser plugin installed that is affected by multiple vulnerabilities.

Description

The version of Adobe Flash Player installed on the remote macOS or Mac OS X host is equal or prior to version 31.0.0.153.
It is therefore affected by the following vulnerabilities :

- An unspecified use-after-free error exists that allows remote code execution. (CVE-2018-15982)

- An unspecified insecure library loading error exists that allows privilege escalation. (CVE-2018-15983)

Solution

Upgrade to Adobe Flash Player version 32.0.0.101 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb18-42.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: High

ID: 119424

File Name: macosx_flash_player_apsb18-42.nasl

Version: 1.2

Type: local

Agent: macosx

Published: 2018/12/06

Modified: 2018/12/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-15982

CVSS v2.0

Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Patch Publication Date: 2018/12/05

Vulnerability Publication Date: 2018/12/05

Reference Information

CVE: CVE-2018-15982, CVE-2018-15983

IAVA: 2018-A-0388