Wireshark 2.4.x < 2.4.11 Multiple Vulnerabilities

Medium Nessus Plugin ID 119419

Synopsis

An application installed on the remote Windows host is affected by multiple vulnerabilities.

Description

The version of Wireshark installed on the remote Windows host is 2.4.x prior to 2.4.11. It is, therefore, affected by multiple vulnerabilities.

Solution

Upgrade to Wireshark version 2.4.11 or later.

See Also

https://www.wireshark.org/docs/relnotes/wireshark-2.4.11.html

https://www.wireshark.org/security/wnpa-sec-2018-51.html

https://www.wireshark.org/security/wnpa-sec-2018-52.html

https://www.wireshark.org/security/wnpa-sec-2018-53.html

https://www.wireshark.org/security/wnpa-sec-2018-54.html

https://www.wireshark.org/security/wnpa-sec-2018-55.html

https://www.wireshark.org/security/wnpa-sec-2018-56.html

Plugin Details

Severity: Medium

ID: 119419

File Name: wireshark_2_4_11.nasl

Version: 1.1

Type: local

Agent: windows

Family: Windows

Published: 2018/12/05

Modified: 2018/12/05

Dependencies: 34112

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-19622

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: installed_sw/Wireshark, SMB/Registry/Enumerated

Patch Publication Date: 2018/11/27

Vulnerability Publication Date: 2018/11/27

Reference Information

CVE: CVE-2018-19622, CVE-2018-19623, CVE-2018-19624, CVE-2018-19625, CVE-2018-19626, CVE-2018-19627

BID: 106051