RHEL 7 : OpenShift Container Platform 3.6 (RHSA-2018:1233)

Medium Nessus Plugin ID 119395

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An update is now available for Red Hat OpenShift Container Platform 3.6.

Red Hat Product Security has rated this update as having a security impact of Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Red Hat OpenShift Container Platform is the company's cloud computing Platform-as-a-Service (PaaS) solution designed for on-premise or private cloud deployments.

This advisory contains RPM packages for this release. See the following advisory for the container images for this release :

https://access.redhat.com/errata/RHBA-2018:1232

Security Fix(es) :

* source-to-image: Improper path sanitization in ExtractTarStreamFromTarReader in tar/tar.go (CVE-2018-1102)

This update also fixes the following bugs :

* Image validation used to validate old image objects, and an invalid image could be pushed to etcd. With this bug fix, validation has been changed to validate new image objects, and as a result it is no longer possible to upload an invalid image object. (BZ#1559982)

* A panic could occur due to concurrent writes to cache. This bug fix protects writes to the cache with mutex. As a result, the cache is safe to use concurrently. (BZ#1549916)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

Update the affected packages.

See Also

https://access.redhat.com/errata/RHSA-2018:1233

https://access.redhat.com/security/cve/cve-2018-1102

Plugin Details

Severity: Medium

ID: 119395

File Name: redhat-RHSA-2018-1233.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/12/04

Modified: 2018/12/04

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:atomic-openshift, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-clients, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-clients-redistributable, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-cluster-capacity, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-docker-excluder, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-dockerregistry, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-excluder, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-federation-services, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-master, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-node, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-pod, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-sdn-ovs, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-service-catalog, p-cpe:/a:redhat:enterprise_linux:atomic-openshift-tests, p-cpe:/a:redhat:enterprise_linux:rubygem-cool.io, p-cpe:/a:redhat:enterprise_linux:rubygem-cool.io-debuginfo, p-cpe:/a:redhat:enterprise_linux:rubygem-cool.io-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-excon, p-cpe:/a:redhat:enterprise_linux:rubygem-excon-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-faraday, p-cpe:/a:redhat:enterprise_linux:rubygem-faraday-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-ffi, p-cpe:/a:redhat:enterprise_linux:rubygem-ffi-debuginfo, p-cpe:/a:redhat:enterprise_linux:rubygem-fluent-plugin-kubernetes_metadata_filter, p-cpe:/a:redhat:enterprise_linux:rubygem-fluent-plugin-kubernetes_metadata_filter-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-fluent-plugin-systemd, p-cpe:/a:redhat:enterprise_linux:rubygem-fluent-plugin-systemd-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-minitest, p-cpe:/a:redhat:enterprise_linux:rubygem-minitest-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-msgpack, p-cpe:/a:redhat:enterprise_linux:rubygem-msgpack-debuginfo, p-cpe:/a:redhat:enterprise_linux:rubygem-msgpack-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-multi_json, p-cpe:/a:redhat:enterprise_linux:rubygem-multi_json-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-systemd-journal, p-cpe:/a:redhat:enterprise_linux:rubygem-systemd-journal-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-tzinfo, p-cpe:/a:redhat:enterprise_linux:rubygem-tzinfo-data, p-cpe:/a:redhat:enterprise_linux:rubygem-tzinfo-data-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-tzinfo-doc, p-cpe:/a:redhat:enterprise_linux:rubygem-unf_ext, p-cpe:/a:redhat:enterprise_linux:rubygem-unf_ext-debuginfo, p-cpe:/a:redhat:enterprise_linux:rubygem-unf_ext-doc, p-cpe:/a:redhat:enterprise_linux:tuned-profiles-atomic-openshift-node, cpe:/o:redhat:enterprise_linux:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2018/04/30

Reference Information

CVE: CVE-2018-1102

RHSA: 2018:1233