mod_python < 2.7.9 / 3.0.4 Malformed Query String DoS

Medium Nessus Plugin ID 11937


The remote web server is prone to a denial of service attack.


The remote host is using the Apache mod_python module older than 2.7.9 or 3.0.4. These versions may be prone to a denial of service attacks when handling malformed queries.


Upgrade to mod_python 2.7.9 / 3.0.4 or later.

See Also

Plugin Details

Severity: Medium

ID: 11937

File Name: mod_python_malformed_query.nasl

Version: $Revision: 1.21 $

Type: remote

Family: Web Servers

Published: 2003/12/04

Modified: 2014/05/26

Dependencies: 10107, 10386, 17975

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 2003/12/01

Reference Information

CVE: CVE-2003-0973

BID: 9129

OSVDB: 2885