RHEL 7 : openshift (RHSA-2015:1736)

Medium Nessus Plugin ID 119361

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

Updated openshift packages that fix one security issue are now
available for Red Hat OpenShift Enterprise 3.0.

Red Hat Product Security has rated this update as having Moderate
security impact. A Common Vulnerability Scoring System (CVSS) base
score, which gives a detailed severity rating, is available from the
CVE link in the References section.

Red Hat OpenShift Enterprise is a cloud computing Platform-as-a-
Service (PaaS) solution designed for on-premise or private cloud
deployments.

Improper error handling in the API server can cause the master process
to crash. A user with network access to the master could cause this to
happen. (CVE-2015-5250)

This issue was discovered by Jordan Liggitt of the Red Hat OpenShift
Enterprise Team.

All OpenShift Enterprise 3.0 users are advised to upgrade to these
updated packages, which correct this issue.

Solution

Update the affected packages.

See Also

https://access.redhat.com/errata/RHSA-2015:1736

https://access.redhat.com/security/cve/cve-2015-5250

Plugin Details

Severity: Medium

ID: 119361

File Name: redhat-RHSA-2015-1736.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/12/04

Modified: 2018/12/04

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:openshift, p-cpe:/a:redhat:enterprise_linux:openshift-clients, p-cpe:/a:redhat:enterprise_linux:openshift-master, p-cpe:/a:redhat:enterprise_linux:openshift-node, p-cpe:/a:redhat:enterprise_linux:openshift-sdn-ovs, p-cpe:/a:redhat:enterprise_linux:tuned-profiles-openshift-node, cpe:/o:redhat:enterprise_linux:7

Patch Publication Date: 2015/09/03

Reference Information

CVE: CVE-2015-5250

RHSA: 2015:1736