RHEL 7 : openshift (RHSA-2015:1650)

High Nessus Plugin ID 119360

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

Updated openshift packages that fix one security issue are now available for Red Hat OpenShift Enterprise 3.0.

Red Hat Product Security has rated this update as having Important security impact. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available from the CVE link in the References section.

Red Hat OpenShift Enterprise is a cloud computing Platform-as-a-Service (PaaS) solution designed for on-premise or private cloud deployments.

An improper permission check issue was discovered in the server admission control component in OpenShift. A user with build permissions could use this flaw to execute arbitrary shell commands on a build pod with the privileges of the root user. (CVE-2015-5222)

This issue was discovered by Cesar Wong of the Red Hat OpenShift Enterprise Team.

All OpenShift Enterprise users are advised to upgrade to these updated packages, which correct this issue.

Solution

Update the affected packages.

See Also

https://access.redhat.com/errata/RHSA-2015:1650

https://access.redhat.com/security/cve/cve-2015-5222

Plugin Details

Severity: High

ID: 119360

File Name: redhat-RHSA-2015-1650.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/12/04

Modified: 2018/12/04

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 8.5

Vector: CVSS2#AV:N/AC:M/Au:S/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:openshift, p-cpe:/a:redhat:enterprise_linux:openshift-clients, p-cpe:/a:redhat:enterprise_linux:openshift-master, p-cpe:/a:redhat:enterprise_linux:openshift-node, p-cpe:/a:redhat:enterprise_linux:openshift-sdn-ovs, p-cpe:/a:redhat:enterprise_linux:tuned-profiles-openshift-node, cpe:/o:redhat:enterprise_linux:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2015/08/20

Reference Information

CVE: CVE-2015-5222

RHSA: 2015:1650