Kubernetes 1.x < 1.10.11 / 1.11.x < 1.11.5 / 1.12.x < 1.12.3 API Server Privilege Escalation

Critical Nessus Plugin ID 119327


The remote host contains an application affected by a privilege escalation vulnerability.


The version of Kubernetes installed on the remote host is version 1.x prior to 1.10.11, 1.11.x prior to 1.11.5, or 1.12.x prior to 1.12.3, and thus, is affected by a remote, unauthenticated privilege escalation vulnerability.

Note that a successful attack requires that an API extension server is directly accessible from the Kubernetes API server's network or that a cluster has granted pod exec, attach, portforward permissions too loosely.


Upgrade to Kubernetes 1.10.11, 1.11.5, 1.12.3 or later.

See Also






Plugin Details

Severity: Critical

ID: 119327

File Name: kube_1_12_3.nasl

Version: 1.5

Type: local

Agent: unix

Family: CGI abuses

Published: 2018/12/04

Updated: 2019/04/05

Dependencies: 112063

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2018-1002105

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:kubernetes:kubernetes, cpe:/a:google:kubernetes

Required KB Items: installed_sw/Kubernetes, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/12/03

Vulnerability Publication Date: 2018/12/03

Reference Information

CVE: CVE-2018-1002105