Kubernetes 1.x < 1.10.11 / 1.11.x < 1.11.5 / 1.12.x < 1.12.3 API Server Privilege Escalation

Critical Nessus Plugin ID 119327

Synopsis

The remote host contains an application affected by a privilege escalation vulnerability.

Description

The version of Kubernetes installed on the remote host is version 1.x prior to 1.10.11, 1.11.x prior to 1.11.5, or 1.12.x prior to 1.12.3, and thus, is affected by a remote, unauthenticated privilege escalation vulnerability.

Note that a successful attack requires that an API extension server is directly accessible from the Kubernetes API server's network or that a cluster has granted pod exec, attach, portforward permissions too loosely.

Solution

Upgrade to Kubernetes 1.10.11, 1.11.5, 1.12.3 or later.

See Also

http://www.nessus.org/u?24a13549

http://www.nessus.org/u?98c83f19

http://www.nessus.org/u?ec479a99

http://www.nessus.org/u?e1cc1943

https://github.com/kubernetes/kubernetes/issues/71411

Plugin Details

Severity: Critical

ID: 119327

File Name: kube_1_12_3.nasl

Version: 1.3

Type: local

Agent: unix

Family: CGI abuses

Published: 2018/12/04

Modified: 2018/12/11

Dependencies: 112063

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2018-1002105

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:google:kubernetes

Required KB Items: installed_sw/kubernetes, Settings/ParanoidReport

Patch Publication Date: 2018/12/03

Vulnerability Publication Date: 2018/12/03

Reference Information

CVE: CVE-2018-1002105