GLSA-201812-02 : ConnMan: Multiple vulnerabilities

High Nessus Plugin ID 119321

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201812-02 (ConnMan: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in ConnMan. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker, via a crafted DNS packet, could remotely execute code or cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All ConnMan users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-misc/connman-1.35-r1'

See Also

https://security.gentoo.org/glsa/201812-02

Plugin Details

Severity: High

ID: 119321

File Name: gentoo_GLSA-201812-02.nasl

Version: 1.1

Type: local

Published: 2018/12/03

Modified: 2018/12/03

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:connman, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/12/02

Reference Information

CVE: CVE-2017-12865, CVE-2017-5716

GLSA: 201812-02