Debian DLA-1601-1 : perl security update

High Nessus Plugin ID 119311

Synopsis

The remote Debian host is missing a security update.

Description

Jayakrishna Menon and Christophe Hauser discovered an integer overflow vulnerability in Perl_my_setenv leading to a heap-based buffer overflow with attacker-controlled input.

For Debian 8 'Jessie', this problem has been fixed in version 5.20.2-3+deb8u12.

We recommend that you upgrade your perl packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00039.html

https://packages.debian.org/source/jessie/perl

Plugin Details

Severity: High

ID: 119311

File Name: debian_DLA-1601.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2018/12/01

Modified: 2018/12/14

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libperl-dev, p-cpe:/a:debian:debian_linux:libperl5.20, p-cpe:/a:debian:debian_linux:perl, p-cpe:/a:debian:debian_linux:perl-base, p-cpe:/a:debian:debian_linux:perl-debug, p-cpe:/a:debian:debian_linux:perl-doc, p-cpe:/a:debian:debian_linux:perl-modules, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/30

Reference Information

CVE: CVE-2018-18311

IAVA: 2018-A-0407