Virtuozzo 6 : samba4 / samba4-client / samba4-common / samba4-dc / etc (VZLSA-2017-2791)

Medium Nessus Plugin ID 119227

Synopsis

The remote Virtuozzo host is missing a security update.

Description

An update for samba4 is now available for Red Hat Enterprise Linux 6.

Red Hat Product Security has rated this update as having a security
impact of Moderate. A Common Vulnerability Scoring System (CVSS) base
score, which gives a detailed severity rating, is available for each
vulnerability from the CVE link(s) in the References section.

Samba is an open source implementation of the Server Message Block
(SMB) or Common Internet File System (CIFS) protocol, which allows
PC-compatible machines to share files, printers, and other
information.

Security Fix(es) :

* It was found that samba did not enforce 'SMB signing' when certain
configuration options were enabled. A remote attacker could launch a
man-in-the-middle attack and retrieve information in plain-text.
(CVE-2017-12150)

* An information leak flaw was found in the way SMB1 protocol was
implemented by Samba. A malicious client could use this flaw to dump
server memory contents to a file on the samba share or to a shared
printer, though the exact area of server memory cannot be controlled
by the attacker. (CVE-2017-12163)

Red Hat would like to thank the Samba project for reporting
CVE-2017-12150 and Yihan Lian and Zhibin Hu (Qihoo 360 GearTeam),
Stefan Metzmacher (SerNet), and Jeremy Allison (Google) for reporting
CVE-2017-12163. Upstream acknowledges Stefan Metzmacher (SerNet) as
the original reporter of CVE-2017-12150.

Note that Tenable Network Security has attempted to extract the
preceding description block directly from the corresponding Red Hat
security advisory. Virtuozzo provides no description for VZLSA
advisories. Tenable has attempted to automatically clean and format
it as much as possible without introducing additional issues.

Solution

Update the affected samba4 / samba4-client / samba4-common / samba4-dc / etc package.

See Also

http://www.nessus.org/u?4d38a13b

https://access.redhat.com/errata/RHSA-2017:2791

Plugin Details

Severity: Medium

ID: 119227

File Name: Virtuozzo_VZLSA-2017-2791.nasl

Version: 1.1

Type: local

Published: 2018/11/27

Modified: 2018/11/27

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

CVSS v3.0

Base Score: 7.4

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:virtuozzo:virtuozzo:samba4, p-cpe:/a:virtuozzo:virtuozzo:samba4-client, p-cpe:/a:virtuozzo:virtuozzo:samba4-common, p-cpe:/a:virtuozzo:virtuozzo:samba4-dc, p-cpe:/a:virtuozzo:virtuozzo:samba4-dc-libs, p-cpe:/a:virtuozzo:virtuozzo:samba4-devel, p-cpe:/a:virtuozzo:virtuozzo:samba4-libs, p-cpe:/a:virtuozzo:virtuozzo:samba4-pidl, p-cpe:/a:virtuozzo:virtuozzo:samba4-python, p-cpe:/a:virtuozzo:virtuozzo:samba4-test, p-cpe:/a:virtuozzo:virtuozzo:samba4-winbind, p-cpe:/a:virtuozzo:virtuozzo:samba4-winbind-clients, p-cpe:/a:virtuozzo:virtuozzo:samba4-winbind-krb5-locator, cpe:/o:virtuozzo:virtuozzo:6

Patch Publication Date: 2017/09/21

Reference Information

CVE: CVE-2017-12150, CVE-2017-12163