GLSA-201811-18 : Tablib: Arbitrary command execution

High Nessus Plugin ID 119163

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201811-18 (Tablib: Arbitrary command execution)

A vulnerability was discovered in Tablib’s Databook loading functionality, due to improper input validation.
Impact :

A remote attacker, by enticing the user to process a specially crafted Databook via YAML, could possibly execute arbitrary python commands with the privilege of the process.
Workaround :

There is no known workaround at this time.

Solution

All Tablib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-python/tablib-0.12.1'

See Also

https://security.gentoo.org/glsa/201811-18

Plugin Details

Severity: High

ID: 119163

File Name: gentoo_GLSA-201811-18.nasl

Version: 1.1

Type: local

Published: 2018/11/27

Modified: 2018/11/27

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:tablib, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/11/27

Reference Information

CVE: CVE-2017-2810

GLSA: 201811-18