Debian DLA-1589-1 : keepalived security update

High Nessus Plugin ID 119152

Synopsis

The remote Debian host is missing a security update.

Description

keepalived has a heap-based buffer overflow when parsing HTTP status codes resulting in DoS or possibly unspecified other impact, because extract_status_code in lib/html.c has no validation of the status code and instead writes an unlimited amount of data to the heap.

For Debian 8 'Jessie', this problem has been fixed in version 1:1.2.13-1+deb8u1.

We recommend that you upgrade your keepalived packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected icecast2 package.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00034.html

https://packages.debian.org/source/jessie/icecast2

Plugin Details

Severity: High

ID: 119152

File Name: debian_DLA-1589.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/27

Modified: 2018/11/27

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:icecast2, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/26

Reference Information

CVE: CVE-2018-19115