Debian DLA-1588-1 : icecast2 security update

High Nessus Plugin ID 119151

Synopsis

The remote Debian host is missing a security update.

Description

A buffer overflow was discovered in the URL-authentication backend of the icecast2, the popular open source streaming media server. If the backend is enabled, then any malicious HTTP client can send a request for specific resource including a crafted header which can overwrite the server's stack contents, leading to denial of service and potentially remote code execution.

For Debian 8 'Jessie', this problem has been fixed in version 2.4.0-1.1+deb8u2.

We recommend that you upgrade your icecast2 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected icecast2 package.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00033.html

https://packages.debian.org/source/jessie/icecast2

Plugin Details

Severity: High

ID: 119151

File Name: debian_DLA-1588.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/27

Modified: 2018/11/27

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:icecast2, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/26

Reference Information

CVE: CVE-2018-18820