Debian DSA-4343-1 : liblivemedia - security update

High Nessus Plugin ID 119124

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that a buffer overflow in liveMedia, a set of C++ libraries for multimedia streaming could result in the execution of arbitrary code when parsing a malformed RTSP stream.

Solution

Upgrade the liblivemedia packages.

For the stable distribution (stretch), this problem has been fixed in version 2016.11.28-1+deb9u1.

See Also

http://www.nessus.org/u?ae949efb

https://packages.debian.org/source/stretch/liblivemedia

https://www.debian.org/security/2018/dsa-4343

Plugin Details

Severity: High

ID: 119124

File Name: debian_DSA-4343.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/26

Modified: 2018/11/26

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:liblivemedia, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/23

Reference Information

CVE: CVE-2018-4013

DSA: 4343