Debian DLA-1594-1 : xml-security-c security update

High Nessus Plugin ID 119122

Synopsis

The remote Debian host is missing a security update.

Description

A vulnerability in xml-security-c, a library for the XML Digital
Security specification, has been found. Different KeyInfo
combinations, like signatures without public key, result in incomplete
DSA structures that crash openssl during verification.

This vulnerability does not have a CVE identifier yet.

For Debian 8 'Jessie', this problem has been fixed in version
1.7.2-3+deb8u2.

We recommend that you upgrade your xml-security-c packages.

NOTE: Tenable Network Security has extracted the preceding description
block directly from the DLA security advisory. Tenable has attempted
to automatically clean and format it as much as possible without
introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00030.html

https://packages.debian.org/source/jessie/xml-security-c

Plugin Details

Severity: High

ID: 119122

File Name: debian_DLA-1594.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/26

Modified: 2018/11/26

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libxml-security-c-dev, p-cpe:/a:debian:debian_linux:libxml-security-c17, p-cpe:/a:debian:debian_linux:xml-security-c-utils, cpe:/o:debian:debian_linux:8.0

Patch Publication Date: 2018/11/24