Debian DLA-1590-1 : openjdk-7 security update

Medium Nessus Plugin ID 119105

Synopsis

The remote Debian host is missing a security update.

Description

Several vulnerabilities have been discovered in OpenJDK, an implementation of the Oracle Java platform, resulting in denial of service, sandbox bypass, incomplete TLS identity verification, information disclosure or the execution of arbitrary code.

For Debian 8 'Jessie', these problems have been fixed in version 7u181-2.6.14-2~deb8u1.

We recommend that you upgrade your openjdk-7 packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00026.html

https://packages.debian.org/source/jessie/openjdk-7

Plugin Details

Severity: Medium

ID: 119105

File Name: debian_DLA-1590.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/23

Modified: 2018/11/23

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:icedtea-7-jre-jamvm, p-cpe:/a:debian:debian_linux:openjdk-7-dbg, p-cpe:/a:debian:debian_linux:openjdk-7-demo, p-cpe:/a:debian:debian_linux:openjdk-7-doc, p-cpe:/a:debian:debian_linux:openjdk-7-jdk, p-cpe:/a:debian:debian_linux:openjdk-7-jre, p-cpe:/a:debian:debian_linux:openjdk-7-jre-headless, p-cpe:/a:debian:debian_linux:openjdk-7-jre-lib, p-cpe:/a:debian:debian_linux:openjdk-7-jre-zero, p-cpe:/a:debian:debian_linux:openjdk-7-source, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/22

Reference Information

CVE: CVE-2018-2952, CVE-2018-3136, CVE-2018-3139, CVE-2018-3149, CVE-2018-3169, CVE-2018-3180, CVE-2018-3214