Debian DLA-1587-1 : pixman security update

High Nessus Plugin ID 119104

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2015-5297 Numerical overflow in pointer arithmetic.

For Debian 8 'Jessie', this problem has been fixed in version 0.32.6-3+deb8u1.

We recommend that you upgrade your pixman packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00025.html

https://packages.debian.org/source/jessie/pixman

Plugin Details

Severity: High

ID: 119104

File Name: debian_DLA-1587.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/23

Modified: 2018/11/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libpixman-1-0, p-cpe:/a:debian:debian_linux:libpixman-1-0-dbg, p-cpe:/a:debian:debian_linux:libpixman-1-0-udeb, p-cpe:/a:debian:debian_linux:libpixman-1-dev, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/22

Reference Information

CVE: CVE-2015-5297