Debian DLA-1585-1 : ruby-rack security update

High Nessus Plugin ID 119102

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there was an XSS vulnerability in the ruby-rack web-server library.

A malicious request could impact the HTTP/HTTPS scheme being returned to the underlying application.

For Debian 8 'Jessie', this issue has been fixed in ruby-rack version 1.5.2-3+deb8u2.

We recommend that you upgrade your ruby-rack packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected ruby-rack package.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00022.html

https://packages.debian.org/source/jessie/ruby-rack

Plugin Details

Severity: High

ID: 119102

File Name: debian_DLA-1585.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/23

Modified: 2018/11/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby-rack, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/21

Reference Information

CVE: CVE-2018-16471