Debian DLA-1584-1 : ruby-i18n security update

High Nessus Plugin ID 119101

Synopsis

The remote Debian host is missing a security update.

Description

It was discovered that there was a remote denial of service vulnerability in ruby-i18n, a I18n and localization solution for Ruby.

An application crash could be engineering a situation where `:some_key` is present in the `keep_keys` structure but not present in the hash.

For Debian 8 'Jessie', this issue has been fixed in ruby-i18n version 0.6.9-2+deb8u1.

We recommend that you upgrade your ruby-i18n packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected ruby-i18n package.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00021.html

https://packages.debian.org/source/jessie/ruby-i18n

Plugin Details

Severity: High

ID: 119101

File Name: debian_DLA-1584.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/23

Modified: 2018/11/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ruby-i18n, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/21

Reference Information

CVE: CVE-2014-10077