VMware Workstation 14.x < 14.1.5 / 15.x < 15.0.2 Virtual Network Integer Overflow Vulnerability (VMSA-2018-0030)

High Nessus Plugin ID 119098

Synopsis

A virtualization application installed on the remote Windows host is affected by anl integer overflow vulnerability.

Description

The version of VMware Workstation installed on the remote host is 14.x prior to 14.1.5 or 15.x prior to 15.0.2. It is, therefore, affected by integer overflow vulnerability in the virtual network devices. An attacker with access to a guest system may be able to execute code on the host system by leveraging this vulnerability.

Solution

Upgrade to VMware Workstation version 14.1.5, 15.0.2, or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2018-0030.html

Plugin Details

Severity: High

ID: 119098

File Name: vmware_workstation_vmsa_2018_0030.nasl

Version: 1.2

Type: local

Family: General

Published: 2018/11/23

Modified: 2018/11/29

Dependencies: 26201, 71053

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-6983

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: installed_sw/VMware Workstation

Patch Publication Date: 2018/11/22

Vulnerability Publication Date: 2018/11/22

Reference Information

CVE: CVE-2018-6983

BID: 105986

VMSA: 2018-0030

IAVA: 2018-A-0387