EulerOS Virtualization 2.5.1 : pam (EulerOS-SA-2018-1375)

Medium Nessus Plugin ID 119066

Synopsis

The remote EulerOS Virtualization host is missing a security update.

Description

According to the version of the pam package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerability :

- It was discovered that the _unix_run_helper_binary() function of PAM's unix_pam module could write to a blocking pipe, possibly causing the function to become unresponsive. An attacker able to supply large passwords to the unix_pam module could use this flaw to enumerate valid user accounts, or cause a denial of service on the system.(CVE-2015-3238)

Note that Tenable Network Security has extracted the preceding description block directly from the EulerOS security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Update the affected pam package.

See Also

http://www.nessus.org/u?7343b0b9

Plugin Details

Severity: Medium

ID: 119066

File Name: EulerOS_SA-2018-1375.nasl

Version: 1.1

Type: local

Published: 2018/11/21

Modified: 2018/11/21

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:pam, cpe:/o:huawei:euleros:uvp:2.5.1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/EulerOS/release, Host/EulerOS/rpm-list, Host/EulerOS/uvp_version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2018/11/12

Reference Information

CVE: CVE-2015-3238

BID: 75428