Debian DLA-1582-1 : liblivemedia security update

High Nessus Plugin ID 119054

Synopsis

The remote Debian host is missing a security update.

Description

A stack based buffer overflow vulnerability was found in liblivemedia, the LIVE555 RTSP server library. This issue might be leveraged by remote attackers to cause code execution, by sending a crafted packet.

For Debian 8 'Jessie', this problem has been fixed in version 2014.01.13-1+deb8u1.

We recommend that you upgrade your liblivemedia packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/11/msg00020.html

https://packages.debian.org/source/jessie/liblivemedia

Plugin Details

Severity: High

ID: 119054

File Name: debian_DLA-1582.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/21

Modified: 2018/11/21

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libbasicusageenvironment0, p-cpe:/a:debian:debian_linux:libgroupsock1, p-cpe:/a:debian:debian_linux:liblivemedia-dev, p-cpe:/a:debian:debian_linux:liblivemedia23, p-cpe:/a:debian:debian_linux:libusageenvironment1, p-cpe:/a:debian:debian_linux:livemedia-utils, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/20

Reference Information

CVE: CVE-2018-4013