VMware vRealize Automation 7.0.x / 7.1.x / 7.2.x / 7.3.x Session IDs Handling Vulnerability (VMSA-2018-0009)

High Nessus Plugin ID 119038

Synopsis

A virtualization appliance installed on the remote host is affected by vulnerability in session tokens handling mechanisms.

Description

The version of VMware vRealize Automation installed on the remote host is 7.0.x, 7.1.x, 7.2.x, or 7.3.x. It is, therefore, affected by a vulnerability in handling of session IDs. Exploitation of this issue may lead to the hijacking of a valid vRA user's session.

Solution

Upgrade to VMware vRealize Automation version 7.4.0 or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2018-0009.html

Plugin Details

Severity: High

ID: 119038

File Name: vmware_vsphere_vrealize_automation_vmsa-2018-0009_CVE-2018-6959.nasl

Version: 1.1

Type: local

Family: Misc.

Published: 2018/11/19

Modified: 2018/11/19

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-6959

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:vmware:vrealize_automation

Required KB Items: Host/VMware vRealize Automation/Version

Patch Publication Date: 2018/04/13

Vulnerability Publication Date: 2018/04/13

Reference Information

CVE: CVE-2018-6959

BID: 103752

VMSA: 2018-0009