Asterisk 15.x < 15.6.2 / 16.x < 16.0.1 DoS (AST-2018-010)

high Nessus Plugin ID 118974
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


A telephony application running on the remote host is affected by a denial of service vulnerability.


According to its SIP banner, the version of Asterisk running on the remote host is 15.x prior to 15.6.2, 16.x prior to 16.0.1. It is therefore, affected by an error related to the functions 'dns_srv' and 'dns_naptr' described in AST-2018-010. This error allows denial of service attacks.

Also note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Asterisk version 15.6.2 / 16.0.1 or later.

See Also

Plugin Details

Severity: High

ID: 118974

File Name: asterisk_ast_2018_010.nasl

Version: 1.4

Type: remote

Family: Misc.

Published: 11/15/2018

Updated: 6/3/2021

Dependencies: asterisk_detection.nasl

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2018-19278


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C


Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 11/14/2018

Vulnerability Publication Date: 10/23/2018

Reference Information

CVE: CVE-2018-19278

BID: 105934

IAVA: 2018-A-0380-S