Asterisk 15.x < 15.6.2 / 16.x < 16.0.1 DoS (AST-2018-010)

Medium Nessus Plugin ID 118974

Synopsis

A telephony application running on the remote host is affected by a denial of service vulnerability.

Description

According to its SIP banner, the version of Asterisk running on the remote host is 15.x prior to 15.6.2, 16.x prior to 16.0.1. It is therefore, affected by an error related to the functions 'dns_srv' and 'dns_naptr' described in AST-2018-010. This error allows denial of service attacks.

Also note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Asterisk version 15.6.2 / 16.0.1 or later.

See Also

http://downloads.asterisk.org/pub/security/AST-2018-010.html

Plugin Details

Severity: Medium

ID: 118974

File Name: asterisk_ast_2018_010.nasl

Version: 1.2

Type: remote

Family: Misc.

Published: 2018/11/15

Updated: 2018/11/29

Dependencies: 63202

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-19278

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Vulnerability Information

CPE: cpe:/a:digium:asterisk

Required KB Items: asterisk/sip_detected, Settings/ParanoidReport

Patch Publication Date: 2018/11/14

Vulnerability Publication Date: 2018/10/23

Reference Information

CVE: CVE-2018-19278

BID: 105934

IAVA: 2018-A-0380