nginx 1.x < 1.14.1 / 1.15.x < 1.15.6 Multiple Vulnerabilties

High Nessus Plugin ID 118956

Synopsis

The remote web server is affected by multiple vulnerabilities.

Description

According to its Server response header, the installed version of nginx is 1.x prior to 1.14.1 or 1.15.x prior to 1.15.6. It is, therefore, affected by the following issues :

- An unspecified error exists related to the module 'ngx_http_v2_module' that allows excessive memory usage.
(CVE-2016-16843)

- An unspecified error exists related to the module 'ngx_http_v2_module' that allows excessive CPU usage.
(CVE-2016-16844)

- An unspecified error exists related to the module 'ngx_http_mp4_module' that allows worker process crashes or memory disclosure. (CVE-2016-16845)

Solution

Upgrade to nginx 1.14.1 / 1.15.6 or later.

See Also

http://nginx.org/en/security_advisories.html

http://mailman.nginx.org/pipermail/nginx-announce/2018/000220.html

http://mailman.nginx.org/pipermail/nginx-announce/2018/000221.html

Plugin Details

Severity: High

ID: 118956

File Name: nginx_1_15_6.nasl

Version: 1.4

Type: remote

Family: Web Servers

Published: 2018/11/14

Updated: 2019/04/04

Dependencies: 106375

Risk Information

Risk Factor: High

CVSS Score Source: manual

CVSS Score Rationale: Composite vector of multiple vulnerabilities in the given version

CVSS v2.0

Base Score: 8.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:C

CVSS v3.0

Base Score: 8.2

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Vulnerability Information

CPE: cpe:/a:igor_sysoev:nginx

Patch Publication Date: 2018/11/06

Vulnerability Publication Date: 2018/01/06

Reference Information

CVE: CVE-2018-16843, CVE-2018-16844, CVE-2018-16845

BID: 105868

IAVB: 2018-B-0143