Node.js multiple vulnerabilities (August 2018 Security Releases).

Medium Nessus Plugin ID 118937


Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.


The version of Node.js installed on the remote host is 6.x prior to 6.14.4, 8.x prior to 8.11.4 or 10.x prior to 10.9.0.
It, therefore, is affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade Node.js to a recommended by vendor version or above

See Also

Plugin Details

Severity: Medium

ID: 118937

File Name: nodejs_2018_aug.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/11/14

Updated: 2018/11/14

Dependencies: 11936, 110839

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-7166

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2018/08/16

Vulnerability Publication Date: 2018/08/11

Reference Information

CVE: CVE-2018-0732, CVE-2018-0737, CVE-2018-7166, CVE-2018-12115

BID: 104442, 103766, 105127