Node.js Multiple Vulnerabilities (August 2018 Security Releases)

high Nessus Plugin ID 118937

Synopsis

Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.

Description

The version of Node.js installed on the remote host is 6.x prior to 6.14.4, 8.x prior to 8.11.4 or 10.x prior to 10.9.0. It is, therefore, affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Node.js to a recommended by vendor version or above.

See Also

http://www.nessus.org/u?f738f917

Plugin Details

Severity: High

ID: 118937

File Name: nodejs_2018_aug.nasl

Version: 1.4

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 11/14/2018

Updated: 12/4/2020

Supported Sensors: Nessus Agent

Risk Information

CVSS Score Source: CVE-2018-7166

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: installed_sw/Node.js

Exploit Ease: No known exploits are available

Patch Publication Date: 8/16/2018

Vulnerability Publication Date: 8/11/2018

Reference Information

CVE: CVE-2018-0732, CVE-2018-0737, CVE-2018-7166, CVE-2018-12115

BID: 103766, 104442, 105127