Node.js multiple vulnerabilities (March 2018 Security Releases).

Medium Nessus Plugin ID 118933

Synopsis

Node.js - JavaScript run-time environment is affected by multiple vulnerabilities.

Description

The version of Node.js installed on the remote host is 4.x prior to 4.9.0, 6.x prior to 6.14.0, 8.x prior to 8.11.0 or 9.x prior to 9.10.0.
It, therefore, is affected by multiple vulnerabilities.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade Node.js to a recommended by vendor version or above

See Also

http://www.nessus.org/u?d516633a

Plugin Details

Severity: Medium

ID: 118933

File Name: nodejs_2018_mar.nasl

Version: 1.1

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/11/14

Updated: 2018/11/14

Dependencies: 110839, 11936

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2018-7160

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 8.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:nodejs:node.js

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2018/03/28

Vulnerability Publication Date: 2018/03/21

Reference Information

CVE: CVE-2018-7160, CVE-2018-7159, CVE-2018-7158