Cfengine cfservd ReceiveTransaction Function Remote Overflow (intrusive check)

High Nessus Plugin ID 11893


The remote host is affected by a remote buffer overflow vulnerability.


The remote Cfserver seems to be vulnerable to a remote buffer overflow bug. Such a bug might be exploited by an attacker to execute arbitrary code on this host, with the privileges cfservd is running with.


Upgrade to version 2.0.8/2.0.8p1 or later.

See Also

Plugin Details

Severity: High

ID: 11893

File Name: gnu_cfserv.nasl

Version: $Revision: 1.20 $

Type: remote

Published: 2003/10/16

Modified: 2017/05/16

Dependencies: 17975

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

Required KB Items: Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/09/25

Vulnerability Publication Date: 2003/09/25

Reference Information

CVE: CVE-2003-0849

BID: 8699

OSVDB: 2611

Secunia: 9855