Debian DSA-4336-1 : ghostscript - security update

Medium Nessus Plugin ID 118893

Synopsis

The remote Debian host is missing a security-related update.

Description

Several vulnerabilities were discovered in Ghostscript, the GPL PostScript/PDF interpreter, which may result in denial of service, disclosure of existence and size of arbitrary files, or the execution of arbitrary code if a malformed Postscript file is processed (despite the dSAFER sandbox being enabled).

This update rebases ghostscript for stretch to the upstream version 9.25 which includes additional non-security related changes.

Solution

Upgrade the ghostscript packages.

For the stable distribution (stretch), these problems have been fixed in version 9.25~dfsg-0+deb9u1.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910678

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=910758

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911175

https://security-tracker.debian.org/tracker/source-package/ghostscript

https://packages.debian.org/source/stretch/ghostscript

https://www.debian.org/security/2018/dsa-4336

Plugin Details

Severity: Medium

ID: 118893

File Name: debian_DSA-4336.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2018/11/13

Updated: 2019/04/05

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSS v3.0

Base Score: 8.6

Temporal Score: 7.7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:ghostscript, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/11/10

Vulnerability Publication Date: 2018/06/01

Reference Information

CVE: CVE-2018-11645, CVE-2018-17961, CVE-2018-18073, CVE-2018-18284

DSA: 4336