GLSA-201811-04 : Mozilla Firefox: Multiple vulnerabilities

Medium Nessus Plugin ID 118848

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201811-04 (Mozilla Firefox: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Mozilla Firefox. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could entice a user to view a specially crafted web page, possibly resulting in the execution of arbitrary code with the privileges of the process, cause a Denial of Service condition, bypass access restriction, access otherwise protected information.
Workaround :

There is no known workaround at this time.

Solution

All Mozilla Firefox users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/firefox-60.3.0' All Mozilla Firefox binary users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=www-client/firefox-bin-60.3.0'

See Also

https://www.mozilla.org/en-US/security/advisories/mfsa2018-27/

https://security.gentoo.org/glsa/201811-04

Plugin Details

Severity: Medium

ID: 118848

File Name: gentoo_GLSA-201811-04.nasl

Version: 1.1

Type: local

Published: 2018/11/09

Modified: 2018/11/09

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:firefox, p-cpe:/a:gentoo:linux:firefox-bin, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Patch Publication Date: 2018/11/09

Reference Information

CVE: CVE-2018-12389, CVE-2018-12390, CVE-2018-12392, CVE-2018-12393, CVE-2018-12395, CVE-2018-12396, CVE-2018-12397

GLSA: 201811-04