GLSA-201811-03 : OpenSSL: Denial of service

high Nessus Plugin ID 118847

Synopsis

The remote Gentoo host is missing one or more security-related patches.

Description

The remote host is affected by the vulnerability described in GLSA-201811-03 (OpenSSL: Denial of service)

It was discovered that OpenSSL allow malicious servers to send very large primes to a client during DH(E) based TLS handshakes.
Impact :

A remote attacker, by sending large prime to client during DH(E) TLS handshake, could possibly cause a Denial of Service condition.
Workaround :

There is no known workaround at this time.

Solution

All OpenSSL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=dev-libs/openssl-1.0.2o-r6'

See Also

https://security.gentoo.org/glsa/201811-03

Plugin Details

Severity: High

ID: 118847

File Name: gentoo_GLSA-201811-03.nasl

Version: 1.3

Type: local

Published: 11/9/2018

Updated: 5/27/2021

Risk Information

VPR

Risk Factor: Medium

Score: 5.1

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:openssl, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Ease: No known exploits are available

Patch Publication Date: 11/9/2018

Vulnerability Publication Date: 6/12/2018

Reference Information

CVE: CVE-2018-0732

GLSA: 201811-03