Debian DSA-4335-1 : nginx - security update

High Nessus Plugin ID 118840

Synopsis

The remote Debian host is missing a security-related update.

Description

Three vulnerabilities were discovered in Nginx, a high-performance web
and reverse proxy server, which could result in denial of service in
processing HTTP/2 (via excessive memory/CPU usage) or server memory
disclosure in the ngx_http_mp4_module module (used for server-side MP4
streaming).

Solution

Upgrade the nginx packages.

For the stable distribution (stretch), these problems have been fixed
in version 1.10.3-1+deb9u2.

See Also

https://security-tracker.debian.org/tracker/source-package/nginx

https://packages.debian.org/source/stretch/nginx

https://www.debian.org/security/2018/dsa-4335

Plugin Details

Severity: High

ID: 118840

File Name: debian_DSA-4335.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2018/11/09

Modified: 2018/12/13

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:nginx, cpe:/o:debian:debian_linux:9.0

Patch Publication Date: 2018/11/08

Reference Information

CVE: CVE-2018-16843, CVE-2018-16844, CVE-2018-16845

DSA: 4335

IAVB: 2018-B-0143