Oracle Linux 7 : curl / nss-pem (ELSA-2018-3157)

High Nessus Plugin ID 118775

Synopsis

The remote Oracle Linux host is missing one or more security updates.

Description

From Red Hat Security Advisory 2018:3157 :

An update for curl and nss-pem is now available for Red Hat Enterprise
Linux 7.

Red Hat Product Security has rated this update as having a security
impact of Moderate. A Common Vulnerability Scoring System (CVSS) base
score, which gives a detailed severity rating, is available for each
vulnerability from the CVE link(s) in the References section.

The curl packages provide the libcurl library and the curl utility for
downloading files from servers using various protocols, including
HTTP, FTP, and LDAP.

The nss-pem package provides the PEM file reader for Network Security
Services (NSS) implemented as a PKCS#11 module.

Security Fix(es) :

* curl: HTTP authentication leak in redirects (CVE-2018-1000007)

* curl: FTP path trickery leads to NIL byte out of bounds write
(CVE-2018-1000120)

* curl: RTSP RTP buffer over-read (CVE-2018-1000122)

* curl: Out-of-bounds heap read when missing RTSP headers allows
information leak of denial of service (CVE-2018-1000301)

* curl: LDAP NULL pointer dereference (CVE-2018-1000121)

For more details about the security issue(s), including the impact, a
CVSS score, and other related information, refer to the CVE page(s)
listed in the References section.

Red Hat would like to thank the Curl project for reporting these
issues. Upstream acknowledges Craig de Stigter as the original
reporter of CVE-2018-1000007; Duy Phan Thanh as the original reporter
of CVE-2018-1000120; Max Dymond as the original reporter of
CVE-2018-1000122; the OSS-fuzz project as the original reporter of
CVE-2018-1000301; and Dario Weisser as the original reporter of
CVE-2018-1000121.

Additional Changes :

For detailed information on changes in this release, see the Red Hat
Enterprise Linux 7.6 Release Notes linked from the References section.

Solution

Update the affected curl and / or nss-pem packages.

See Also

https://oss.oracle.com/pipermail/el-errata/2018-November/008192.html

Plugin Details

Severity: High

ID: 118775

File Name: oraclelinux_ELSA-2018-3157.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/07

Modified: 2018/11/07

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:oracle:linux:curl, p-cpe:/a:oracle:linux:libcurl, p-cpe:/a:oracle:linux:libcurl-devel, p-cpe:/a:oracle:linux:nss-pem, cpe:/o:oracle:linux:7

Patch Publication Date: 2018/11/06

Reference Information

CVE: CVE-2018-1000007, CVE-2018-1000120, CVE-2018-1000121, CVE-2018-1000122, CVE-2018-1000301

RHSA: 2018:3157