EulerOS 2.0 SP3 : krb5 (EulerOS-SA-2018-1361)

Medium Nessus Plugin ID 118755

Synopsis

The remote EulerOS host is missing multiple security updates.

Description

According to the versions of the krb5 packages installed, the EulerOS
installation on the remote host is affected by the following
vulnerabilities :

- A denial of service flaw was found in MIT Kerberos
krb5kdc service. An authenticated attacker could use
this flaw to cause krb5kdc to exit with an assertion
failure by making an invalid S4U2Self or S4U2Proxy
request.(CVE-2017-11368)

- An authentication bypass flaw was found in the way
krb5's certauth interface handled the validation of
client certificates. A remote attacker able to
communicate with the KDC could potentially use this
flaw to impersonate arbitrary principals under rare and
erroneous circumstances.(CVE-2017-7562)

Note that Tenable Network Security has extracted the preceding
description block directly from the EulerOS security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

Solution

Update the affected krb5 packages.

See Also

http://www.nessus.org/u?cf858d19

Plugin Details

Severity: Medium

ID: 118755

File Name: EulerOS_SA-2018-1361.nasl

Version: 1.23

Type: local

Published: 2018/11/07

Modified: 2019/01/02

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: p-cpe:/a:huawei:euleros:krb5-devel, p-cpe:/a:huawei:euleros:krb5-libs, p-cpe:/a:huawei:euleros:krb5-pkinit, p-cpe:/a:huawei:euleros:krb5-server, p-cpe:/a:huawei:euleros:krb5-server-ldap, p-cpe:/a:huawei:euleros:krb5-workstation, p-cpe:/a:huawei:euleros:libkadm5, cpe:/o:huawei:euleros:2.0

Patch Publication Date: 2018/10/28

Reference Information

CVE: CVE-2017-11368, CVE-2017-7562