Apache Struts <= 2.3.36 FileUpload Deserialization Vulnerability

High Nessus Plugin ID 118732

Synopsis

A web application running on the remote host uses a Java framework that is affected by multiple denial of service vulnerabilities.

Description

The version of Apache Struts running on the remote host is 2.3.36 or prior. It is, therefore, affected by the following vulnerability:

- A deserialization vulnerability in Apache Commons FileUpload which could be leveraged for remote code execution. (CVE-2016-1000031)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Struts version 2.5.12 or later.
Alternatively, apply the workaround referenced in the vendor advisory.

See Also

http://www.nessus.org/u?ed31d635

https://www.tenable.com/security/research/tra-2016-12

Plugin Details

Severity: High

ID: 118732

File Name: struts_2_3_36_fileupload.nasl

Version: 1.3

Type: local

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/11/05

Modified: 2018/11/09

Dependencies: 99671, 73943, 11936

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2016-1000031

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2016/10/25

Reference Information

CVE: CVE-2016-1000031

BID: 93604

TRA: TRA-2016-12

IAVA: 2018-A-0355