Apache Struts 2.3.x < 2.3.33 Denial of Service (S2-049)

Medium Nessus Plugin ID 118731


A web application running on the remote host uses a Java framework that is affected by multiple denial of service vulnerabilities.


The version of Apache Struts running on the remote host is 2.3.x prior to 2.3.33. It is, therefore, affected by the following vulnerability:

- A flaw exists in unspecified Spring AOP functionality that is used to secure Struts actions. An authenticated, remote attacker can exploit this to cause a denial of service condition. (CVE-2017-9787)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Struts version 2.3.33 or later.
Alternatively, apply the workaround referenced in the vendor advisory.

See Also



Plugin Details

Severity: Medium

ID: 118731

File Name: struts_2_3_33.nasl

Version: 1.2

Type: combined

Agent: windows, macosx, unix

Family: Misc.

Published: 2018/11/05

Updated: 2019/02/15

Dependencies: 73943, 99671, 11936, 122235

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2017-9787

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:struts

Required KB Items: Settings/ParanoidReport

Patch Publication Date: 2017/07/11

Vulnerability Publication Date: 2017/07/11

Reference Information

CVE: CVE-2017-9787

BID: 99563