Debian DSA-4334-1 : mupdf - security update

Medium Nessus Plugin ID 118723

Synopsis

The remote Debian host is missing a security-related update.

Description

Multiple vulnerabilities were discovered in MuPDF, a PDF, XPS, and e-book viewer which could result in denial of service or the execution of arbitrary code if malformed documents are opened.

Solution

Upgrade the mupdf packages.

For the stable distribution (stretch), these problems have been fixed in version 1.9a+ds1-4+deb9u4.

See Also

https://security-tracker.debian.org/tracker/source-package/mupdf

https://packages.debian.org/source/stretch/mupdf

https://www.debian.org/security/2018/dsa-4334

Plugin Details

Severity: Medium

ID: 118723

File Name: debian_DSA-4334.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/11/05

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.8

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mupdf, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/11/04

Reference Information

CVE: CVE-2017-17866, CVE-2018-1000037, CVE-2018-1000040, CVE-2018-5686, CVE-2018-6187, CVE-2018-6192

DSA: 4334