F5 Networks BIG-IP : BIG-IP tmsh vulnerability (K01067037)

High Nessus Plugin ID 118615

Synopsis

The remote device is missing a vendor-supplied security patch.

Description

When BIG-IP is licensed for Appliance mode, Admin and Resource administrator roles can by-pass BIG-IP Appliance mode restrictions to overwrite critical system files. (CVE-2018-15321)

Attackers with ahigh-privilege level can overwrite critical system files, which in turnbypasses security controls thatlimit TMOS Shell ( tmsh ) commands.This scenario is possible when the Administrator orResource Administrator roles are granted tmsh access.Resource Administrator roles must have tmsh access to perform this attack.

Note : F5 does not consider the capability of Advanced Shell ( bash ) access in this vulnerability, as users granted that level of access can simply perform any command as root. This vulnerability is an issue for Appliance mode, users who are granted tmsh access, and for the Resource Administrator role when operating in standard, non-Appliance mode.

Impact

When the BIG-IP system is licensed for Appliance mode, Administrator and Resource Administrator roles can by-pass BIG-IP Appliance mode restrictions to overwrite critical system files.

Solution

Upgrade to one of the non-vulnerable versions listed in the F5 Solution K01067037.

See Also

https://support.f5.com/csp/#/article/K01067037

Plugin Details

Severity: High

ID: 118615

File Name: f5_bigip_SOL01067037.nasl

Version: 1.1

Type: local

Published: 2018/11/02

Modified: 2018/11/02

Dependencies: 76940

Risk Information

Risk Factor: High

Vulnerability Information

CPE: cpe:/a:f5:big-ip_access_policy_manager, cpe:/a:f5:big-ip_advanced_firewall_manager, cpe:/a:f5:big-ip_application_acceleration_manager, cpe:/a:f5:big-ip_application_security_manager, cpe:/a:f5:big-ip_application_visibility_and_reporting, cpe:/a:f5:big-ip_global_traffic_manager, cpe:/a:f5:big-ip_link_controller, cpe:/a:f5:big-ip_local_traffic_manager, cpe:/a:f5:big-ip_policy_enforcement_manager, cpe:/a:f5:big-ip_webaccelerator, cpe:/h:f5:big-ip

Required KB Items: Host/local_checks_enabled, Host/BIG-IP/hotfix, Host/BIG-IP/modules, Host/BIG-IP/version, Settings/ParanoidReport

Patch Publication Date: 2018/10/30

Reference Information

CVE: CVE-2018-15321