Debian DLA-1562-1 : poppler security update

Medium Nessus Plugin ID 118578

Synopsis

The remote Debian host is missing a security update.

Description

Various security issues were discovered in the poppler PDF rendering shared library.

CVE-2017-18267

The FoFiType1C::cvtGlyph function in fofi/FoFiType1C.cc in Poppler through 0.64.0 allows remote attackers to cause a denial of service (infinite recursion) via a crafted PDF file, as demonstrated by pdftops.

The applied fix in FoFiType1C::cvtGlyph prevents infinite recursion on such malformed documents.

CVE-2018-10768

A NULL pointer dereference in the AnnotPath::getCoordsLength function in Annot.h in Poppler 0.24.5 had been discovered. A crafted input will lead to a remote denial of service attack. Later versions of Poppler such as 0.41.0 are not affected.

The applied patch fixes the crash on AnnotInk::draw for malformed documents.

CVE-2018-13988

Poppler through 0.62 contains an out of bounds read vulnerability due to an incorrect memory access that is not mapped in its memory space, as demonstrated by pdfunite. This can result in memory corruption and denial of service. This may be exploitable when a victim opens a specially crafted PDF file.

The applied patch fixes crashes when Object has negative number. (Specs say, number has to be > 0 and gen >= 0).

For Poppler in Debian jessie, the original upstream patch has been backported to Poppler's old Object API.

CVE-2018-16646

In Poppler 0.68.0, the Parser::getObj() function in Parser.cc may cause infinite recursion via a crafted file. A remote attacker can leverage this for a DoS attack.

A range of upstream patches has been applied to Poppler's XRef.cc in Debian jessie to consolidate a fix for this issue.

For Debian 8 'Jessie', these problems have been fixed in version 0.26.5-2+deb8u5.

We recommend that you upgrade your poppler packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/10/msg00024.html

https://packages.debian.org/source/jessie/poppler

Plugin Details

Severity: Medium

ID: 118578

File Name: debian_DLA-1562.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/11/01

Modified: 2018/11/01

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:gir1.2-poppler-0.18, p-cpe:/a:debian:debian_linux:libpoppler-cpp-dev, p-cpe:/a:debian:debian_linux:libpoppler-cpp0, p-cpe:/a:debian:debian_linux:libpoppler-dev, p-cpe:/a:debian:debian_linux:libpoppler-glib-dev, p-cpe:/a:debian:debian_linux:libpoppler-glib-doc, p-cpe:/a:debian:debian_linux:libpoppler-glib8, p-cpe:/a:debian:debian_linux:libpoppler-private-dev, p-cpe:/a:debian:debian_linux:libpoppler-qt4-4, p-cpe:/a:debian:debian_linux:libpoppler-qt4-dev, p-cpe:/a:debian:debian_linux:libpoppler-qt5-1, p-cpe:/a:debian:debian_linux:libpoppler-qt5-dev, p-cpe:/a:debian:debian_linux:libpoppler46, p-cpe:/a:debian:debian_linux:poppler-dbg, p-cpe:/a:debian:debian_linux:poppler-utils, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/31

Reference Information

CVE: CVE-2017-18267, CVE-2018-10768, CVE-2018-13988, CVE-2018-16646