RHEL 7 : libkdcraw (RHSA-2018:3065)

Medium Nessus Plugin ID 118522

Synopsis

The remote Red Hat host is missing one or more security updates.

Description

An update for libkdcraw is now available for Red Hat Enterprise Linux 7.

Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.

Libkdcraw is a C++ interface around the LibRaw library used to decode the RAW picture files.

Security Fix(es) :

* LibRaw: Stack-based buffer overflow in quicktake_100_load_raw() function in internal/dcraw_common.cpp (CVE-2018-5805)

* LibRaw: Heap-based buffer overflow in LibRaw::kodak_ycbcr_load_raw function in internal/dcraw_common.cpp (CVE-2018-5800)

* LibRaw: NULL pointer dereference in LibRaw::unpack function src/ libraw_cxx.cpp (CVE-2018-5801)

* LibRaw: Out-of-bounds read in kodak_radc_load_raw function internal/ dcraw_common.cpp (CVE-2018-5802)

* LibRaw: NULL pointer dereference in leaf_hdr_load_raw() function in internal/dcraw_common.cpp (CVE-2018-5806)

For more details about the security issue(s), including the impact, a CVSS score, and other related information, refer to the CVE page(s) listed in the References section.

Additional Changes :

For detailed information on changes in this release, see the Red Hat Enterprise Linux 7.6 Release Notes linked from the References section.

Solution

Update the affected libkdcraw, libkdcraw-debuginfo and / or libkdcraw-devel packages.

See Also

http://www.nessus.org/u?3395ff0b

https://access.redhat.com/errata/RHSA-2018:3065

https://access.redhat.com/security/cve/cve-2018-5800

https://access.redhat.com/security/cve/cve-2018-5801

https://access.redhat.com/security/cve/cve-2018-5802

https://access.redhat.com/security/cve/cve-2018-5805

https://access.redhat.com/security/cve/cve-2018-5806

Plugin Details

Severity: Medium

ID: 118522

File Name: redhat-RHSA-2018-3065.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/10/31

Modified: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.2

Vector: CVSS2#AV:L/AC:H/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 7

Vector: CVSS:3.0/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: p-cpe:/a:redhat:enterprise_linux:libkdcraw, p-cpe:/a:redhat:enterprise_linux:libkdcraw-debuginfo, p-cpe:/a:redhat:enterprise_linux:libkdcraw-devel, cpe:/o:redhat:enterprise_linux:7

Required KB Items: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

Patch Publication Date: 2018/10/30

Reference Information

CVE: CVE-2018-5800, CVE-2018-5801, CVE-2018-5802, CVE-2018-5805, CVE-2018-5806

RHSA: 2018:3065