GLSA-201810-09 : X.Org X Server: Privilege escalation

High Nessus Plugin ID 118509

Synopsis

The remote Gentoo host is missing one or more security-related
patches.

Description

The remote host is affected by the vulnerability described in GLSA-201810-09
(X.Org X Server: Privilege escalation)

An incorrect permission check for -modulepath and -logfile options when
starting Xorg. X server allows unprivileged users with the ability to log
in to the system via physical console to escalate their privileges and
run arbitrary code under root privileges.
Impact :

A local attacker can escalate privileges to root by passing crafted
parameters to the X.org X server.
Workaround :

There is no known workaround at this time.

Solution

All X.Org X Server users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=x11-base/xorg-server-1.20.3'

See Also

https://security.gentoo.org/glsa/201810-09

Plugin Details

Severity: High

ID: 118509

File Name: gentoo_GLSA-201810-09.nasl

Version: 1.3

Type: local

Published: 2018/10/31

Modified: 2018/11/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:xorg-server, cpe:/o:gentoo:linux

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/10/30

Exploitable With

Metasploit (Xorg X11 Server SUID privilege escalation)

Reference Information

CVE: CVE-2018-14665

GLSA: 201810-09

IAVB: 2018-B-0140