PHP < 4.3.3 Multiple Vulnerabilities

high Nessus Plugin ID 11850


Arbitrary code may be run on the remote server.


The remote host is running a version of PHP that is older than 4.3.3.

All versions of PHP 4 older than 4.3.3 contain multiple integer overflow vulnerabilities that may allow an attacker to execute arbitrary commands on this host. Another problem may also invalidate safe_mode.


Upgrade to PHP 4.3.3.

See Also

Plugin Details

Severity: High

ID: 11850

File Name: php4_multiple_flaws.nasl

Version: 1.36

Type: remote

Family: CGI abuses

Published: 9/24/2003

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Vulnerability Publication Date: 12/27/2002

Reference Information

CVE: CVE-2002-1396, CVE-2003-0442, CVE-2003-0860, CVE-2003-0861

BID: 6488, 7761, 8693, 8696

RHSA: 2003:204-01

SuSE: SUSE-SA:2003:0009