Debian DSA-4328-1 : xorg-server - security update

High Nessus Plugin ID 118474

Synopsis

The remote Debian host is missing a security-related update.

Description

Narendra Shinde discovered that incorrect command-line parameter
validation in the Xorg X server may result in arbitary file overwrite,
which can result in privilege escalation.

Solution

Upgrade the xorg-server packages.

For the stable distribution (stretch), this problem has been fixed in
version 2:1.19.2-1+deb9u4.

See Also

https://security-tracker.debian.org/tracker/source-package/xorg-server

https://packages.debian.org/source/stretch/xorg-server

https://www.debian.org/security/2018/dsa-4328

Plugin Details

Severity: High

ID: 118474

File Name: debian_DSA-4328.nasl

Version: 1.5

Type: local

Agent: unix

Published: 2018/10/29

Modified: 2018/11/23

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:xorg-server, cpe:/o:debian:debian_linux:9.0

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2018/10/25

Exploitable With

Metasploit (Xorg X11 Server SUID privilege escalation)

Reference Information

CVE: CVE-2018-14665

DSA: 4328

IAVB: 2018-B-0140