Debian DLA-1555-1 : libmspack security update

High Nessus Plugin ID 118468

Synopsis

The remote Debian host is missing a security update.

Description

CVE-2018-18584 Fixing the size of the CAB block input buffer, which is too small for the maximal Quantum block, prevents an out-of-bounds write.

CVE-2018-18585 Blank filenames (having length zero or their 1st or 2nd byte is null) should be rejected.

For Debian 8 'Jessie', these problems have been fixed in version 0.5-1+deb8u3.

We recommend that you upgrade your libmspack packages.

NOTE: Tenable Network Security has extracted the preceding description block directly from the DLA security advisory. Tenable has attempted to automatically clean and format it as much as possible without introducing additional issues.

Solution

Upgrade the affected packages.

See Also

https://lists.debian.org/debian-lts-announce/2018/10/msg00017.html

https://packages.debian.org/source/jessie/libmspack

Plugin Details

Severity: High

ID: 118468

File Name: debian_DLA-1555.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/29

Modified: 2018/10/29

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:libmspack-dbg, p-cpe:/a:debian:debian_linux:libmspack-dev, p-cpe:/a:debian:debian_linux:libmspack-doc, p-cpe:/a:debian:debian_linux:libmspack0, cpe:/o:debian:debian_linux:8.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/26

Reference Information

CVE: CVE-2018-18584, CVE-2018-18585