VMware Workstation 14.x < 14.1.3 Out-of-Bounds Read Vulnerability (VMSA-2018-0026) (Linux)

High Nessus Plugin ID 118464

Synopsis

A virtualization application installed on the remote Linux host is affected by an out-of-bounds read vulnerability.

Description

The version of VMware Workstation installed on the remote Linux host is 14.x prior to 14.1.3. It is, therefore, affected by an out-of-bounds read vulnerability in SVGA devices. An attacker with access to a guest system may be able to execute code on the host system by leveraging this vulnerability.

Solution

Upgrade to VMware Workstation version 14.1.3 or later.

See Also

https://www.vmware.com/security/advisories/VMSA-2018-0026.html

Plugin Details

Severity: High

ID: 118464

File Name: vmware_workstation_linux_vmsa_2018_0026.nasl

Version: 1.1

Type: local

Family: General

Published: 2018/10/26

Modified: 2018/10/26

Dependencies: 71053

Risk Information

Risk Factor: High

CVSS Score Source: CVE-2018-6974

CVSS v2.0

Base Score: 7.2

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS v3.0

Base Score: 9.3

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:vmware:workstation

Required KB Items: Host/VMware Workstation/Version, Settings/ParanoidReport

Excluded KB Items: SMB/Registry/Enumerated

Patch Publication Date: 2018/10/16

Vulnerability Publication Date: 2018/10/16

Reference Information

CVE: CVE-2018-6974

BID: 105660

VMSA: 2018-0026