Debian DSA-4325-1 : mosquitto - security update

Medium Nessus Plugin ID 118408

Synopsis

The remote Debian host is missing a security-related update.

Description

It was discovered that mosquitto, an MQTT broker, was vulnerable to remote denial-of-service attacks that could be mounted using various vectors.

Solution

Upgrade the mosquitto packages.

For the stable distribution (stretch), these problems have been fixed in version 1.4.10-3+deb9u2.

See Also

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911265

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=911266

https://security-tracker.debian.org/tracker/source-package/mosquitto

https://packages.debian.org/source/stretch/mosquitto

https://www.debian.org/security/2018/dsa-4325

Plugin Details

Severity: Medium

ID: 118408

File Name: debian_DSA-4325.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2018/10/26

Modified: 2018/11/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: p-cpe:/a:debian:debian_linux:mosquitto, cpe:/o:debian:debian_linux:9.0

Required KB Items: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

Patch Publication Date: 2018/10/25

Reference Information

CVE: CVE-2017-7651, CVE-2017-7652, CVE-2017-7653, CVE-2017-7654

DSA: 4325