Amazon Linux 2 : git (ALAS-2018-1093)

High Nessus Plugin ID 118400

Synopsis

The remote Amazon Linux 2 host is missing a security update.

Description

Git before 2.14.5, allows remote code execution during processing of a recursive 'git clone' of a superproject if a .gitmodules file has a URL field beginning with a '-' character.(CVE-2018-17456)

Solution

Run 'yum update git' to update your system.

See Also

https://alas.aws.amazon.com/AL2/ALAS-2018-1093.html

Plugin Details

Severity: High

ID: 118400

File Name: al2_ALAS-2018-1093.nasl

Version: 1.1

Type: local

Agent: unix

Published: 2018/10/26

Modified: 2018/10/26

Dependencies: 12634

Risk Information

Risk Factor: High

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:git, p-cpe:/a:amazon:linux:git-all, p-cpe:/a:amazon:linux:git-core, p-cpe:/a:amazon:linux:git-core-doc, p-cpe:/a:amazon:linux:git-cvs, p-cpe:/a:amazon:linux:git-daemon, p-cpe:/a:amazon:linux:git-debuginfo, p-cpe:/a:amazon:linux:git-email, p-cpe:/a:amazon:linux:git-gnome-keyring, p-cpe:/a:amazon:linux:git-gui, p-cpe:/a:amazon:linux:git-p4, p-cpe:/a:amazon:linux:git-svn, p-cpe:/a:amazon:linux:gitk, p-cpe:/a:amazon:linux:gitweb, p-cpe:/a:amazon:linux:perl-Git, p-cpe:/a:amazon:linux:perl-Git-SVN, cpe:/o:amazon:linux:2

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 2018/10/25

Reference Information

CVE: CVE-2018-17456

ALAS: 2018-1093