Sendmail < 8.12.10 prescan() Function Remote Overflow

Critical Nessus Plugin ID 11838


The remote mail server is prone to multiple buffer overflow attacks.


According to its version number, the remote sendmail server is between 5.79 to 8.12.9. Such versions are reportedly vulnerable to remote buffer overflow attacks, one in the 'prescan()' function and another involving its ruleset processing. A remote user may be able to leverage these issues to gain root privileges.


Upgrade to Sendmail version 8.12.10 or later.

See Also

Plugin Details

Severity: Critical

ID: 11838

File Name: sendmail_prescan_overflow.nasl

Version: $Revision: 1.34 $

Type: remote

Published: 2003/09/17

Modified: 2018/02/27

Dependencies: 10263

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 9.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND


Base Score: 10

Temporal Score: 9.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:F/RL:X/RC:X

Vulnerability Information

CPE: cpe:/a:sendmail:sendmail

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2003/09/17

Vulnerability Publication Date: 2003/09/17

Reference Information

CVE: CVE-2003-0681, CVE-2003-0694

BID: 8641, 8649

OSVDB: 2577

CERT: 108964

RHSA: 2003:283